Model libraries for monolithic and multilayer varistors

The libraries enable PSpice users to simulate overvoltage protection with the entire standard range of EPCOS varistors. Information on how to integrate the libraries into PSpice is given in the readme file.

 

The libraries require PSpice version 8 or following.

 

What is new?

  • The libraries now cover monolithic and multilayer varistors (CTVS) in separate files.
  • The library for automotive multilayer varistors was added including the E series.

Download library for monolithic varistors

Download library for standard multilayer varistors

Download library for automotive series of multilayer varistors

 

Our website uses cookies to provide you with the best possible service. More information about the use of cookies on this website and how they can be disabled is available on our information page. With your consent, you confirm that you have read the information about the use of cookies and accept it. Please also note our further information on the subject of data privacy policy.